Webform trigger with empty table

Hi everyone,

is it possible to use a table field in a webform trigger, in order to receive a variable number of inputs?
Right now we're using a file field where the user uploads an excel, and I tried to replace it with an empty data table that I created.
However, since the user didn't had an account, the table was not loading for her.
What could be done to solve this problem?

Answers

  • Meghan_550057Meghan_550057 Posts: 107
    edited August 2020

    @Lucas_116196 - you can certainly have a table used in a webform trigger. The below is what you'll configure:

    1. In the Data section of Catalytic, upload the shell of your table for what needs to be entered. Here, I have a sample of a table I configured with only one column with the File type:

    2. On your webform trigger, add a field with the Table type and select the name of the table you configured in step #1.

    3. When you access the webform (with or without a Catalytic account), the table will appear to edit. The user can add multiple rows and add multiple files. Sample below:

    There shouldn't be any suppressed visibility of your table if it's on the webform trigger. If you're seeing suppressed visibility (perhaps on an Email: Send a form action?), let us know and we can take a look. If you need to send sample links for review, please contact [email protected] so we can have our Support team take a closer look at your process configuration.

  • Hi, Meghan. Thank you for replying me!
    Actually I had created the table just like you showed above. However, when one of the user accessed the webform link, the table was not loading for her, she was getting some error message saying that field was forbidden... (sorry, I don't remember exactly how was the message).

  • Meghan_550057Meghan_550057 Posts: 107
    edited August 2020

    @Lucas_116196 - hm, that's interesting. I tried to test with altering the permissions on the table and the webform field to see if that resulted in forbidden errors. I didn't see any errors appearing on the table on the form. If you're still hearing reports of that occurring, could you email [email protected] with the below? That will help us take a deeper dive into the issue.

    • workflow URL for the impacted form
    • browser type the individual is using when seeing the error
  • @Meghan_550057 has this issue been resolved? I am encountering the same issue with a workflow I've just published.

    Thank you!

  • Hi @Anna_272419, would you be able to share the web form and/or a screen shot of the error message?

  • Kalin_126161Kalin_126161 Posts: 56 admin

    Hi @Anna_272419, we confirmed this is a current bug with versioned workflows with triggers. The recommended workaround at this time is to delete and re-create the trigger in the newest version. Let me know if you have any questions and I will be happy to assist.

Sign In or Register to comment.